読者です 読者をやめる 読者になる 読者になる

にちじょう

日常で気になったものを写真を通して紹介します。

旧バージョン向けプロジェクト

Androidプロジェクトを作成したら、なにやらappcompat_v7とかいうプロジェクトも同時に作成された。ナニコレ。

ググってみたらプロジェクトを作るときAPIレベル13以下のものを含めると作成されてしまう模様。

 

対策として、以下のページを参考にしましたので紹介します。

appcompat_v7の除去(´・ω・`)? | もぐら王国

 

その他やったこと↓

・MainActivity extends 「ActionBarActivity」→「Activity」

ActionBarActivityのほうがいろいろできるらしいけどエラー出てるしぽいぽい。

・onOptionsItemSelectedメソッドを削除

よくわからんけどMenuって書いてあるしMenu使わんから削除。

 

しかしGitがうまく連携できないなぁ・・・eclipseではフツーに実行できるのにAIDEだとコンパイルエラーが出まくる。うーむ?